Below we shall present some brief information regarding the Superhero compatibility with the PHP version. Superhero is 100% compatible with PHP 5.3 +, but WordPress recommends using PHP 7+

 

Also, Superhero is compatible with later versions of PHP 5.2.x. However, you should know that in this case, the demo imports won’t work.

 

Keep in mind that WordPress recommends using PHP 7+, because the other versions have reached the end of their life cycle. Using them might lead to your website being exposed to security vulnerabilities.

 

PHP 5.3, 5.4 and 5.5 shouldn’t be used at all, since they have reached the end of their life cycle. We do support them and they will work with Superhero, but issues may arise, and they can be fixed only partially. 

 

But why do some issues appear?
Well, because certain hosting plans don’t care very much about them, and how much trouble it can cause.

 

The version of choice from now on should be 7+, and consequently, you must look for the host that updates its MySQL and PHP version constantly. We perform tests often in order to make sure that Superhero works properly on them.

 

The support team is here to help you if you encounter any trouble. All you have to do is submit a ticket here and you will soon receive an answer.